The following table lists the third-party dependencies that must be pre-installed before NetBrain components are installed.

System Component

Third-party Dependencies

MongoDB (Linux)

Systemd

License Agent (Linux)

Systemd

Elasticsearch (Linux)

OpenJDK 12.0.1

Redis (Linux)

Logrotate, Systemd, and Firewalld must be pre-installed on the same machine before Redis is installed.

RabbitMQ (Linux)

Erlang-22.1.7

Logrotate, Socat, and Systemd must be pre-installed on the same machine before RabbitMQ is installed.

Web Server
Web API Server
Worker Server

Microsoft Visual C++ 2017 Redistributable

IIS 8/10

Python 3.7.5

Microsoft .NET Framework 4.8

Task Engine

Microsoft Visual C++ 2017 Redistributable

OpenJDK 12.0.1

Front Server Controller

Microsoft Visual C++ 2017 Redistributable

Python 3.7.5

Front Server (Windows)

Microsoft Visual C++ 2017 Redistributable

Python 3.7.5

Front Server (Linux)

Systemd

glibc.x86_64

glibc.i686

libstdc++.x86_64

libstdc++.i686

libuuid.x86_64

libuuid.i686

pam.x86_64

pam.i686

Service Monitor Agent (Windows)

Python 3.7.5

Ansible Agent (add-on)

Ansible Engine 2.5 or higher versions

Git

Paramiko 2.6.0